Previous Entry Share Next Entry
(no subject)
2012
unknownj
Ridiculous!

Trying to book my train tickets for tomorrow, I figured I might as well use Firefox for it, so I go to the website, and am told:
Incompatible Browser

This site requires the use of Internet Explorer 5.5 or later with 128-bit encryption. You are using Netscape 5.0

We strongly recommend that you download the latest version of Internet Explorer for Microsoft Windows or Mac OS
Uh, what? IE5.5 was released in July 2000, I'm currently using Firefox 3, released June 2008.

I mean forealiously, what a POS..
Tags:

  • 1
The website being...?

Name and shame, son.

  • 1
?

Log in

No account? Create an account